Status @ rongyi.io

NRT-Level Heart Rate not available due to upstream endpoint change
Monitoring·Partial outage

Octopus now switched to the undocumented `api.prod` endpoint for heart rate reporting.

Wed, Jun 25, 2025, 07:22 AM
(6 days ago)
·
Affected components
Updates

Monitoring

Octopus now switched to the undocumented `api.prod` endpoint for heart rate reporting.

Wed, Jun 25, 2025, 07:22 AM

Identified

api-7 was suddenly offline. All endpoints under api-7 now return 404 Not Found.

Mon, Jun 23, 2025, 02:00 PM(1 day earlier)

Identified

api-7 endpoint temporarily back online for some reason, monitoring til the next token refresh

Thu, May 22, 2025, 03:50 AM(1 month earlier)

Identified

Authentication now uses an alternate undocumented endpoint under api.prod (auth-service/v2). Login implemented and verified; now awaiting web app token refresh to observe the behavior.

Wed, May 21, 2025, 11:17 PM(4 hours earlier)

Investigating

WHOOP deprecates the api-7 endpoint for user upgraded to the 5.0/MG device. Previous authentication and heart rate history data is no longer accessible after the upgrade.

Wed, May 21, 2025, 07:03 PM(4 hours earlier)
Powered by